User:
Pass:
Keep:   
Xoops Cube Project
XOOPS Cube Project Site
Powered by Google


Powered by XOOPS Cube Legacy 2.1.8
PukiWikiMod 1.5.1
WordPress Module 0.6.0 Alpha
カテゴリーの追加方法 投稿者: Haru 投稿日:2006/12/22(Fri) 19:53 No.3350  
最近、XOOPSを導入してブログモジュールでWORDPRESS MEを使わせていただいております。
素敵なモジュール有難うございます。

さっそくですが、カテゴリーを追加ができなません。
管理画面から、WordPressオプションを開き、[カテゴリ]ボタンを押すと、真っ白な画面が表示されるか、あるいはWORDPRESS Japan という管理画面が表示されてしまい、カテゴリの追加削除画面が表示されません。なにか解決方法はございませんでしょうか?

[環境]
サーバー:
OS: FedoraCore4
PHP: php.i386 5.0.4-10.5
DB: mysql-server.i386 4.1.20-1.FC4.1
XOOPS: XOOPS 2.0
WORDPRESSモジュール: WordPress 0.6.0 Alpha
→WordPress 0.5.0 RC Final Full Version

0.6.0でカテゴリーの追加画面が表示されなかったので、0.5.0でmodules以下を上書きして、XOOPSモジュール管理でアップデートしましたが、同様にカテゴリーの追加ができません。

カテゴリーは初期のGeneralのみです。

お忙しい中とは思いますが、ご教示のほど宜しくお願い致します。


Re: カテゴリーの追加方法 投稿者: Haru 投稿日:2006/12/26(Tue) 00:03 No.3351  

引用:

Haruさんは書きました:

0.6.0でカテゴリーの追加画面が表示されなかったので、0.5.0でmodules以下を上書きして、XOOPSモジュール管理でアップデートしましたが、同様にカテゴリーの追加ができません。

カテゴリーは初期のGeneralのみです。

お忙しい中とは思いますが、ご教示のほど宜しくお願い致します。


自己解決できました。インストールしたWORDXPRESSをアンインストールし、XOOPSのmodulesディレクトリからも削除した後、再度インストールしたら、出来るようになりました。


投稿するたび増えるエラー Notice [PHP]: 投稿者: インアウト 投稿日:2006/12/20(Wed) 19:03 No.3345  
いくつもの素晴らしいモジュールとても感謝しております。

050SnapShotを使わせていただいております。

投稿すると、ページ下部に以下のようなエラーが表示されます。
Notice [PHP]: Uninitialized string offset: 0 in file modules/wordpress/wp-includes/functions-formatting.php line 12

投稿するたびに同じものが複数増えていきます。
最初は060をインストールしていましたが、そのような表示が多かったので、アンインストール&削除して050を試してみたのですが同じ結果になりました。

お忙しいと思いますが、解決方法を何卒ご教授願います。


Re: 投稿するたび増えるエラー Notice [PHP]: 投稿者: nobunobu 投稿日:2006/12/20(Wed) 23:09 No.3346  

これ、PHPのバージョンによって動作が違うのかもしれませんね?
PHPのバージョンはどうなっていますでしょうか?
modules/wordpress/wp-includes/functions-formatting.phpの12行目の

if (isset($curl{0}) && '<' != $curl{0} && $next) { // If it's not a tag



if (!empty($curl{0}) && '<' != $curl{0} && $next) { // If it's not a tag

に変更したらどうなりますでしょうか?


Re[2]: 投稿するたび増えるエラー Notice [PHP]: 投稿者: インアウト 投稿日:2006/12/21(Thu) 13:20 No.3348  

ご回答ありがとうございました。

PHPのバージョンは4.0です。
ソースを変更してアップデートもしてみましたが、エラー表示は変わりませんでした。

他に考えられることはありますでしょうか。
お忙しいところ恐縮ですが、何卒ご教授願います。


Re[3]: 投稿するたび増えるエラー Notice [PHP]: 投稿者: nobunobu 投稿日:2006/12/21(Thu) 21:46 No.3349  

引用:

PHPのバージョンは4.0です。

PHPのバージョンについては、4.0.2 とか 4.4.11とかいうように最後の細かい数字まで
教えて頂けないでしょうか、
もしこれが本当に4.0.xであるならば、まずはXOOPS自体の動作が保証されていません。
http://xoopscube.jp/modules/documents/
にあるように、PHP4.1.0 以降 が対象となります。
再度のご確認をお願いします。


二つ目のWordPressをインストールしたら・・・ 投稿者: toshi 投稿日:2006/11/30(Thu) 18:18 No.3306  
はじめまして、こんにちは。
WordPress 使わさせていただいております。

本日、二つ目のWordPressをインストールしたところ、ユーザのアカウント情報が
見られなくなってしまいました。

アンインストールすると、また見られるようになりました。

どうにか、二つ目も稼動させたいので、ご教授願えないでしょうか?

よろしくお願いいたします。


Re: 二つ目のWordPressをインストールしたら・・・ 投稿者: toshi 投稿日:2006/11/30(Thu) 18:22 No.3307  

申し訳ありません。

過去ログにありました。

多分、コア版と共存させたからかもしれません。

両方、同じ版でもう一度、チャレンジしてみます。

ありがとうございました。


Re[2]: 二つ目のWordPressをインストールしたら・・・ 投稿者: toshi 投稿日:2006/12/01(Fri) 10:16 No.3308  

たびたび、申し訳ありません。。。

コア版、フルセット版ともにだめでした。

同じものでも、2つ入れると、user.phpにアクセスできなくなるようです。

お手数をおかけいたしますが、

ご教授お願いいたします。


Re[3]: 二つ目のWordPressをインストールしたら・・・ 投稿者: nobunobu 投稿日:2006/12/17(Sun) 14:25 No.3332  

レスが遅くなって申し訳ありません。

WordPressのバージョンはどれをお使いですか?


Re[4]: 二つ目のWordPressをインストールしたら・・・ 投稿者: toshi 投稿日:2006/12/18(Mon) 17:30 No.3341  

引用:

nobunobuさんは書きました:
レスが遅くなって申し訳ありません。

WordPressのバージョンはどれをお使いですか?


年末、お忙しいところ申し訳ありません。

0.5.0のFinalを使用させていただきました。

コアバージョン、フルバージョンともに試してみましたが、
どの組み合わせでも、2つインストールをすると、
usr.phpにアクセスできなくなりました。

ひとつ、アンインストールすると、アクセスできるようになるので、
やはり、WordPressが原因ではないかと。。。

また、お手すきのときでもいいので、
ご教授お願いいたします。

以上、よろしくお願いいたします。


Re[5]: 二つ目のWordPressをインストールしたら・・・ 投稿者: nobunobu 投稿日:2006/12/20(Wed) 23:33 No.3347  

モジュール複製時にアカウント情報の表示不具合が発生するというのは、
おそらく検索機能でエラーになっていることが原因なんでしょうけど・・・・
で、WordPress0.5.0 RC-Finalを使用されている他のサイトを調べてみたんですが・・・
googleでなにげにwordpress0という複製時に良く使用されるであろうキーワードで検索してみたら、某自民党大物政治家さんの公式サイトを見付けました。
で・・・・・このサイトWordPressモジュールを4つも複製して使用していただいているようなんですが、このサイトでuserinfo.phpを見させて頂いたのですが正常に表示されて投稿者の投稿記事一覧も表示されています。
(このような表画面で表されていないURLを直打ちテストさせて頂いたので、あえてどなたのサイトかは書きませんが、Googleですぐに見つかりますよ!)

ということで、モジュール複製でも正常に表示されているケースもあるようなので、ある特定の条件下にて不具合が発生するようです。

で幾つか質問させて頂きたいのですが、
1.PHPのバージョンは?
2.サーバーのOSは?
3.サーバーOSがlinuxの場合モジュール複製に、ディスク容量削減の目的で
  シンボリックリンクを使用されていませんよね(この場合複製機能が正常に動作しません)


コメント通知メールについて 投稿者: Pちゃん 投稿日:2006/11/23(Thu) 01:24 No.3300  
いつも、お世話になっています。
wordpressでコメント投稿された場合に、メール通知される設定にしています。
wordpressは2個設置しています。
wordpressではコメントが会った場合には、メールが来ます。
wordpress0では、コメント通知が来ないです。

現在は、0.3.3から0.6.0にバージョンアップしたwordpressを使っています。
0.3.3の時は大丈夫だったのですが...。

お教え願えませんでしょうか?
ちなみにxoopsのバージョンは2.0.13aです。

よろしくお願いします。


Re: コメント通知メールについて 投稿者: nobunobu 投稿日:2006/12/17(Sun) 13:50 No.3328  

大変レスが遅くなって申し訳ありません。

あれ〜・・・おかしいですね。
2つのモジュール間で、設定が異なることは無いでしょうか?


Re[2]: コメント通知メールについて 投稿者: Pちゃん 投稿日:2006/12/19(Tue) 22:57 No.3344  

引用:

あれ〜・・・おかしいですね。
2つのモジュール間で、設定が異なることは無いでしょうか?

妻と使っているので、wordpressとwordpress0ではメール通知のアドレスは違うようにしています。
それじゃだめでしょうか?
0.3.3では、大丈夫だったのですが...


記事ランキングのプラグイン 投稿者: hanamogera 投稿日:2006/12/12(Tue) 00:01 No.3315  
いつも大変お世話になっております。(wordpress共々)
今日、日がな一日解決方法を探したのですがどうしても見つからなかったので質問をさせてください。

Wordpressのプラグインで、記事のランキングというのがあったのですが、
Popularity Contest 日本語版
プラグインをインストールして、これを表示させるにはサイドバーが要るという事で、サイドバーの表示を試みようと探したのですが、その方法が見当たりませんでした。

サイドバーを表示せずともプラグインを使用することはできますか?
また、サイドバーを表示する方法がありましたら教えて下さい。

既出のご質問でしたら大変申し訳ありません。
宜しくお願い致します。


xoops バージョン:2.0.16a-JP
wordpress バージョン:wordpress060_alpha_full


Re: 記事ランキングのプラグイン 投稿者: nobunobu 投稿日:2006/12/17(Sun) 15:23 No.3336  

WordPressのXOOPSモジュール化を行うにあたって、サイドバー部分をすべて、XOOPSのブロックにもっていってしまったのでサイドバーの表示はできません。
サイドバーに、<?php akpc_most_popular(); ?> を貼り付けるとのことなので、
うまくやればXOOPSのPHPカスタムブロックにて対応可能かもしれません。
あと、index-template.php をカスタマイズして、描画域を作成してやることもできますよ。

但し、一応プラグインのソースを見てみましたが、DB操作部分や管理画面などがWPの新しいバージョン用になっているので、当モジュールとは互換性が無いようですね。
一応DBまわりを当モジュール用に修正して試してみましたけど残念ながら設定画面を表示するまでには至りませんでした。


Re[2]: 記事ランキングのプラグイン 投稿者: hanamogera 投稿日:2006/12/19(Tue) 10:11 No.3343  

お返事ありがとうございます!

引用:

WordPressのXOOPSモジュール化を行うにあたって、サイドバー部分をすべて、XOOPSのブロックにもっていってしまったのでサイドバーの表示はできません。
サイドバーに、<?php akpc_most_popular(); ?> を貼り付けるとのことなので、
うまくやればXOOPSのPHPカスタムブロックにて対応可能かもしれません。
あと、index-template.php をカスタマイズして、描画域を作成してやることもできますよ。


なるほど。カスタマイズしないと表示が出来ないのですね。
その方法も試してみようと思います。

引用:

但し、一応プラグインのソースを見てみましたが、DB操作部分や管理画面などがWPの新しいバージョン用になっているので、当モジュールとは互換性が無いようですね。
一応DBまわりを当モジュール用に修正して試してみましたけど残念ながら設定画面を表示するまでには至りませんでした。


バージョンの違いだったのですね!最新を入れたらいいのかと思っていました。。
古いバージョンをインストールして、思索してみようと思います。
色々とありがとう御座います!


| 1| 2| 3| 4| 5| 6| 7| 8| 9| 10| 11| 12| 13| 14| 15| 16| 17| 18| 19| 20| >>|
NO: PASS:

このプログラムは KENT 氏の yybbs を xoops(PHP) に移植したものです
- KENT -